回收思科Cisco 原装全新或二手路由器、交换机、模块等  [star  2012年1月1日]        
网站首页  简介  商品展示  CISCO维修  CISCO续保  CISCO租赁  CISCO回收  最新库存及报价  客户留言
   路由器  |  交换机  |  模块  |  防火墙  |  语音网关  |  电源  |  其它配件  | 风扇  |  服务器  |  资源下载
您现在的位置: 宏信网络 >> 文章中心 >> 资讯中心 >> 技术共享 >> 正文
Google
 
思科Catalyst交换机 IP+MAC绑定
作者:佚名    文章来源:本站原创    点击数:    更新时间:2012-7-3    
一.主机MAC与交换机端口绑定:
switch#config terminal
switch(config)# int f0/1
switch(config-if)#switchport mode access
switch(config-if )#switchport port-security mac-address 0000.0000.0001
 
 
二.主机IP与交换机端口绑定:
switch(config)#interface FastEthernet0/17
switch(config-if)# ip access-group 1 in       
switch(config)#access-list 1 permit 10.0.0.1
 
这样就将交换机的FastEthernet0/17端口与ip,mac绑定了。
 
 
 
最简单的方法
在2960交换机中如何进行端口MAC地址绑定,并同时绑定IP与MAC地址?
arp 192.168.1.1 0000.1001.2200 arpa fa0/1
 
 
据说
启用dhcp snooping可以实现动态的绑定,还可以使用ip source binding命令实现静态的绑定。
 
 
 
 
 
 
 
 
 
 
 
路由交换机mac ip绑定命令
2009-02-14 16:46
在cisco交换机中为了防止ip被盗用或员工乱改ip,可以做以下措施,既ip与mac地址的绑定,和ip与交换机端口的绑定。
一、通过IP查端口
先查MAC地址,再根据MAC地址查端口:
bangonglou3#show arp | include 208.41 通过IP找端口
 
或者show mac-address-table 来查看整个端口的ip-mac表
 
      Internet 10.138.208.41           4   0006.1bde.3de9 ARPA   Vlan10
bangonglou3#show mac-add | in 0006.1bde
    10    0006.1bde.3de9    DYNAMIC     Fa0/17
bangonglou3#exit
 
二、ip与mac地址的绑定,这种绑定可以简单有效的防止ip被盗用,别人将ip改成了你绑定了mac地址的ip后,其网络不同,(tcp/udp协议不同,但netbios网络共项可以访问),具体做法:
    cisco(config)#arp 10.138.208.81 0000.e268.9980 ARPA
这样就将10.138.208.81 与mac:0000.e268.9980 ARPA绑定在一起了
 
三、ip与交换机端口的绑定,此种方法绑定后的端口只有此ip能用,改为别的ip后立即断网。有效的防止了乱改ip。
     cisco(config)# interface FastEthernet0/17
    cisco(config-if)# ip access-group 6 in      
    cisco(config)#access-list 6 permit 10.138.208.81
这样就将交换机的FastEthernet0/17端口与ip:10.138.208.81绑定了。
 
 
 
 
 
 
 
   最常用的对端口安全的理解就是可根据MAC地址来做对网络流量的控制和管理,比如MAC地址与具体的端口绑定,限制具体端口通过的MAC地址的数量,或者在具体的端口不允许某些MAC地址的帧流量通过。
 
1.MAC地址与端口绑定,当发现主机的MAC地址与交换机上指定的MAC地址不同时,交换机相应的端口将down掉。当给端口指定MAC地址时,端口模式必须为access或者Trunk状态。
 
3550-1#conf t
 
3550-1(config)#int f0/1
 
3550-1(config-if)#switchport mode access /指定端口模式。
 
3550-1(config-if)#switchport port-security mac-address 00-90-F5-10-79-C1 /配置MAC地址。
 
3550-1(config-if)#switchport port-security maximum 1 /限制此端口允许通过的MAC地址数为1。
 
这个非常好!
 
3550-1(config-if)#switchport port-security violation shutdown /当发现与上述配置不符时,端口down掉。
 
2.通过MAC地址来限制端口流量,此配置允许一TRUNK口最多通过100个MAC地址,超过100时,但来自新的主机的数据帧将丢失。
 
3550-1#conf t
 
3550-1(config)#int f0/1
 
3550-1(config-if)#switchport trunk encapsulation dot1q
 
3550-1(config-if)#switchport mode trunk /配置端口模式为TRUNK。
 
3550-1(config-if)#switchport port-security maximum 100 /允许此端口通过的最大MAC地址数目为100。
 
3550-1(config-if)#switchport port-security violation protect /当主机MAC地址数目超过100时,交换机继续工作,但来自新的主机的数据帧将丢失。
 
上面的配置根据MAC地址来允许流量,下面的配置则是根据MAC地址来拒绝流量。
 
1.此配置在Catalyst交换机中只能对单播流量进行过滤,对于多播流量则无效。
 
3550-1#conf t
 
3550-1(config)#mac-address-table static 00-90-F5-10-79-C1 vlan 2 drop /在相应的Vlan丢弃流量。
 
3550-1#conf t
 
3550-1(config)#mac-address-table static 00-90-F5-10-79-C1 vlan 2 int f0/1 /在相应的接口丢弃流量。
 
================================
用交换机端口安全 switchport port-secrity
再开启IP原防护 就可以在端口绑定 IP+MAC+端口
有两绑定方法
1.动态绑定 (需要DHCP支持) 通过dhcp绑定 ip+mac+端口 
首先启用DHCP监听 #ip dhcp snooping
                                        #ip dhcp snooping vlan 2
                                       #ip dhcp snooping trust
                           #ip verify source port-security
                           #ip verify source vlan dhcp-snooping port-security
2.静态手动绑定
(接口)#ip source binding H.H.H vlan X ip address interface f0/x
              (ip source binding 0000.0000.0001  vlan 2 192.168.2.1 interface f0/2)
            #ip veritf source port-security



交换机与路由器故障处理方法
思科Nexus数据中心交换机大揭秘
用debug做思科路由交换机故障诊断
千兆管理型交换机网吧方案
经验:速度与带宽在交换机上的大不同
关于我们  联系我们  友情链接  设为首页 加入收藏 网站公告

深圳市欧维创科技有限公司
电话:0755-29309671 13926535432 地址:广东省深圳市龙华新区
Copyright 2001 - 2012 All Rights Reserved 
粤ICP备14059454号